Flutterを3.10にアップグレードしたら「** depends on cupertino_icons >=0.1.1 <1.0.1 which doesn't support null safety」というビルドエラーが出る場合の対処法

日本時間の2023年5月11日未明に開催された「Google I/O」において、Flutterの安定版のバージョンが3.10にアップグレードされましたが、

それに伴い、アップグレード前は正常に動いていたプロジェクトにおいて

** depends on cupertino_icons >=0.1.1 <1.0.1 which doesn’t support null safety

というビルドエラーが発生する可能性があります。

blank

 

このエラーが発生した場合は、以下の要領で「pubspec.yaml」ファイルから「cupertino_icons」パッケージのバージョンを「1.0.1」以降にしてやると解消します。

blank

この「cupertino_icons」パッケージは、Flutterのプロジェクトを新規で作成した際にデフォルトで設定されているパッケージなのですが、

  • Flutterのバージョンが3.10にアップグレードした際に、Flutterアプリを作るためのプログラミング言語である「Dart」の3にアップグレードされ、
  • Dart3以降は、「Null Safety」が完全適用になって、Null Safety対応されていないコードを受け付けなくなったのだが、
  • 「cupertino_icons」のバージョン「1.0.0」以下はNull Safety対応されていないのでエラーになった

というのが発生原因のようです。

blank

 

(詳しくは、以下の動画で解説していますので、よろしければご覧ください)

blank

こんな記事も読まれています

今すぐプレゼントを受け取る(約6時間のFlutter初級編体験版動画講座を無料でプレゼント)
blank

はじめての方へ

blank
みんプロ式プログラミング講座体系・ラインナップ
みんプロ式プログラミング講座受講の流れ(割引特典利用方法)
サイトマップ(みんプロHPコンテンツ一覧)
運営会社概要

おすすめコンテンツ

プログラミングを学ぶとどんないいことがあるのか
みんプロ式を選んでいただける6つの理由
ぼくの人生挫折ヒストリー(代表者プロフィール)
ぼくのプログラミング挫折ヒストリー(無料メール講座・6大特典付き)
今最も注目のアプリ開発ツール「Flutter(フラッター)」ミニ動画講座

みんプロ式動画講座(コア・Flutter)

ゼロからのFlutter(初級編)-はじめてのプログラミングからアプリリリースまで-
Flutter中級編1-Web通信・設計・状態管理・DIの基礎-
Flutter中級編2-Firebase/地図・カメラ連携等の基礎-
Flutter中級編3-広告/アプリ内課金等の基礎-
Flutter中級編4-Webアプリとレスポンシブデザインの基礎-

みんプロ式動画講座(サテライト)

Flutter/Dartトラブルシューティング・小ネタ集(コア初級編受講で無料プレゼント)
ゼロからのGit・GitHub(コマンドラインツールを極力使わないバージョン管理入門)
Flutter/Dartにおける設計・状態管理・DIの解説集
Dart逆引き大辞典
Flutterにおけるテストの基礎
blank
blank

みんプロ作成アプリ

blank
blank
blank
blank

TOP