「flutter_advanced_network_image」を使っている場合はまだFlutterのSDKのバージョンを1.20に上げないで!’DiagnosticableMixin’ not found.という謎のエラーが発生します(8/15時点)

今月初旬にFlutterのSDKの安定版のバージョンが1.20にアップグレードされましたが、これに伴って、「flutter_advanced_networkimage」パッケージが破壊的な影響を受けており、FlutterSDKのバージョンアップにおいつかず、以下のようなエラーが発生します。

../../../flutter/.pub-cache/hosted/pub.dartlang.org/flutter_svg-0.17.4/lib/src/picture_stream.dart:88:26: Error: Type 'DiagnosticableMixin' not found.
class PictureStream with DiagnosticableMixin {

 

おそらく早晩対応されると思いますが、2020/8/15時点ではまだ対応がなされていませんので、それまでの間は、Flutterのバージョンを1.20に上げずにプロジェクトを作成して下さい。(もし上げた場合は「flutter downgrade」でバージョンを1.17.5に落として下さい)

 

flutter_advanced_networkimageで上がっているissue:2020/8/15時点ではまだ解決していません)

(詳しくは、下の動画で解説していますので、そちらをご覧ください)

こんな記事も読まれています

おすすめコンテンツ




Flutter(フラッター)


みんプロ作成アプリ




TOP