【重要】Flutter3での「コード補完効かない問題」はバージョン3.0.5で解消されました(動画なし)

受講生の皆様

平素は、みんプロ式Flutter講座をご受講頂きまして、ありがとうございます。

表題の件につきまして、本日未明にFlutterSDKの安定版が3.0.5にアップグレードされましたが、
https://github.com/flutter/flutter/wiki/Hotfixes-to-the-Stable-Channel#305-july-13-2022

本バージョンにて、以前お伝えした「コード補完効かない問題」がめでたく解消されました。

(「コード補完効かない問題」とは)
「Flutter3」へのアップグレードによりStateクラス(StatefulWidgetの面倒を見る「育ての親」クラス)において使用頻度の高い「initState」「dispose」及び「setState」メソッドをコード補完してくれない事象。

ついては、これをもってFlutterのバージョンを3.0.5にアップグレードして頂けますので、ご希望の方はTerminalより「flutter upgrade」の上行ってください。

(FlutterSDKのアップグレード方法は以下ご参照ください)

(なお、Flutter3.0へのアップグレード時の注意点は以下ご参照ください)

以上、よろしくお願い致します。

こんな記事も読まれています

おすすめコンテンツ






Flutter(フラッター)


みんプロ作成アプリ




TOP