(解消済)本日Flutter3.0.4がリリースされましたが「コード補完効かない問題」が解決していないのでまだアップグレードしないで下さい

(注)本件はバージョン3.0.5にて無事解消されました。

受講生の皆様

平素は、みんプロ式Flutter講座をご受講頂きまして、ありがとうございます。

表題の件につきまして、本日未明にFlutterSDKの安定版が3.0.4にアップグレードされましたが、

以前お伝えした「コード補完効かない問題」がまだ解消されていないため、現時点ではアップグレードせずに、バージョン2.10.5をお使い頂きますようお願い致します。

「コード補完効かない問題」とは
「Flutter3」へのアップグレードによりStateクラス(StatefulWidgetの面倒を見る「育ての親」クラス)において使用頻度の高い「initState」「dispose」及び「setState」メソッドをコード補完してくれない事象。

(Flutter公式にissueを上げています)

(Flutter3.0以上にアップグレードされてしまった方は、以下ご参照頂いて2.10.5にダウングレードして下さい)

また、進展があればご連絡させて頂きます。

以上、よろしくお願い致します。

こんな記事も読まれています

おすすめコンテンツ






Flutter(フラッター)


みんプロ作成アプリ




TOP