[Flutter/Android]geolocatorパッケージ7.7.0以上を使う場合は「compileSdkVersion」を「31」にしないとエラーになります

Flutterで位置情報が取得できることで人気のパッケージである「geolocator」ですが、

このパッケージを使っているFlutterのプロジェクトをAndroidアプリとして動かす際に、「geolocator」のバージョン7.7.0以上を使う場合は、「android/app/build.gradle」ファイル内にある「compileSdkVersion」と「targetSdkVersion」を「31」にする必要があります。

この数値が「30」以下のままでアプリを動かそうとすると、以下のエラーに遭遇してしまいます。

(詳しくは、以下の動画で解説していますので、よろしければご覧下さい)

こんな記事も読まれています

おすすめコンテンツ




Flutter(フラッター)


みんプロ作成アプリ




TOP