[Flutter]「assets_audio_player」パッケージをインストールしようとすると「Pub failed to delete entry because・・」というエラーが出て失敗する場合の対処法(動画なし)

FlutterでBGMを流すための「assets_audio_player」という非常に使い勝手の良いパッケージがありますが、

これをpubspec.yamlファイルから「pub get」してインストールしようとすると、

Pub failed to delete entry because it was in use by another process

というエラーが出て失敗することがあります(Windowsの場合に起こる可能性があるようです)。

こうなってしまった場合は、

1)「assets_audio_player」のバージョンを「3.0.3+3」にダウングレードするか

2)Android Studioを「管理者として実行」してから「assets_audio_player」パッケージをインストールするとうまくいくようです。

ぼくの受講生の方は「2」の方法で解決なさいました。

(パッケージの公式サイトにもissueが上がっていましたが、まだ「Open」状態なので完全な解決には至っていないようです)

こんな記事も読まれています

おすすめコンテンツ




Flutter(フラッター)


みんプロ作成アプリ




TOP