【講座更新連絡:ゼロからのFlutter】2022年3月時点ではDriftパッケージでpath1.8.1を使おうとするとエラーになりますのでご注意下さい(flutter_test from sdk is forbidden)

(注)この記事はみんプロ式Flutter講座をご受講頂いている方向けの講座更新連絡です。リンク先のレクチャーは講座にご登録頂いている方のみご覧頂けますのでご注意願います。

受講生の皆様

平素は、みんプロ式Flutter講座・初級編(ゼロからのFlutter)をご受講頂きまして、ありがとうございます。

表題の件につきまして、本編第7・8章で使用しているデータベース操作パッケージ「Drift」の設定を行う際に、公式リファレンス通りのパッケージ群のバージョンを指定しても、現時点では以下のようなエラーが発生してしまいます。

Because every version of flutter_test from sdk depends on path 1.8.0 and my_own_frashcard depends on path ^1.8.1, flutter_test from sdk is forbidden.
So, because my_own_frashcard depends on flutter_test from sdk, version solving failed.
pub get failed (1; So, because my_own_frashcard depends on flutter_test from sdk, version solving failed.)

blank

この場合は、pathパッケージのバージョンを1.8.0に変更してもらうと解消しますが、これについての解説を以下のレクチャーの1:42付近より追加しましたので、必要な方はご参照下さい。

 

210: Drift(旧:Moor)パッケージをプロジェクトに追加しよう(Driftの使い方9ステップ①)

(質問対応有り版)
https://school.minpro.net/courses/flutter-ios-android/lectures/11938668
(質問対応無し版)
https://school.minpro.net/courses/flutter-ios-android-no-qa/lectures/11951349

(当社HP内にも本件に関する記事をアップしましたので、よろしければご参照下さい)

以上、よろしくお願い致します。

blank

こんな記事も読まれています

今すぐプレゼントを受け取る(約6時間のFlutter初級編体験版動画講座を無料でプレゼント)
blank

はじめての方へ

blank
みんプロ式プログラミング講座体系・ラインナップ
みんプロ式プログラミング講座受講の流れ(割引特典利用方法)
サイトマップ(みんプロHPコンテンツ一覧)
運営会社概要

おすすめコンテンツ

プログラミングを学ぶとどんないいことがあるのか
みんプロ式を選んでいただける6つの理由
ぼくの人生挫折ヒストリー(代表者プロフィール)
ぼくのプログラミング挫折ヒストリー(無料メール講座・6大特典付き)
今最も注目のアプリ開発ツール「Flutter(フラッター)」ミニ動画講座

みんプロ作成アプリ

blank
blank
blank
blank
blank

みんプロ式動画講座(コア・Flutter)

ゼロからのFlutter(初級編)-はじめてのプログラミングからアプリリリースまで-
Flutter中級編1-Web通信・設計・状態管理・DIの基礎-
Flutter中級編2-Firebase/地図・カメラ連携等の基礎-
Flutter中級編3-広告/アプリ内課金等の基礎-
Flutter中級編4-Webアプリとレスポンシブデザインの基礎-

みんプロ式動画講座(サテライト)

Flutter/Dartトラブルシューティング・小ネタ集(コア初級編受講で無料プレゼント)
ゼロからのGit・GitHub(コマンドラインツールを極力使わないバージョン管理入門)
Flutter/Dartにおける設計・状態管理・DIの解説集
Dart逆引き大辞典
Flutterにおけるテストの基礎
blank
blank

TOP