[Flutter]Firebase関連のパッケージはNull Safety対応の最新版(1.0.0)にまだアップグレードしない方がよい(2021/3/7時点・動画なし)

つい先日3月3日のひなまつりの日に、Flutter2.0が安定版としてリリースされました。

今回のアップデートでFirebase関連のパッケージもNull Safety対応の1.0.0にアップグレードされました。

しかし、geocoding等、プロジェクトで使っているパッケージがNull Safety対応されていないものがある場合は、依存関係が解消できないことが判明しました(プロジェクトをNull Safetyに移行するには、プロジェクトで使っているパッケージ群が全てNull Safety対応していないとできない)。

ですので、Firebase関係のパッケージのバージョンは最新版(1.0.0以上)ではなく、Null Safety対応一歩手前の最新版にしておいた方が安全です。

firebase_core: ^0.7.0

firebase_auth: ^0.20.0

cloud_firestore: ^0.16.0

firebase_storage: ^7.0.0

firebase_analytics: ^7.0.0

(2021/3/7時点。いずれ状況は変わると思いますが)

こんな記事も読まれています

おすすめコンテンツ




Flutter(フラッター)


みんプロ作成アプリ




TOP